Skip to main content

Prerequisites

The prerequisites and requirements for installing and running Snow Inventory Oracle Scanner are described below.

Dependency on other Snow products

Snow Inventory Oracle Scanner is started from a Snow Inventory Agent.

Java Runtime Environment

To run Snow Inventory Oracle Scanner, the target computer is required to have Java Runtime Environment 8 (1.8), 11, or 17 installed.

Supported versions of Java Runtime Environments are Oracle Java SE and Oracle OpenJDK (versions 8, 11, and 17).

Permissions and environment variables

If the operating system user running the Snow Inventory Agent is root, all users who run database instances must be members of the operating system DBA group. This is required to get folder permissions for the temp folder.

If the operating system user running the Snow Inventory Agent is not root, the user:

For Linux/Unix environments, the operating system user running Snow Inventory Oracle Scanner must have write permissions on the following directories:

  • on Linux: /var/run/SnowSoftware/Inventory/Agent/script-output

  • on Unix: /var/tmp/SnowSoftware/Inventory/Agent/script-output

For information on supported operating systems, see Snow System Requirements.